SimplyBits - Nogales - Partial Service Outage

Incident Report for Ting Internet

Resolved

Our team has completed the repairs to the impacted site in Nogales. All customers should be back online. If you do not have an internet connection at this time and you were impacted by the outage, please power cycle your router and unplug your Power over Ethernet Adapter for about 10 seconds and plug it back in. This should restore your connection. Thank you.
Posted Aug 21, 2025 - 10:08 EDT

Investigating

Some customers in Nogales may be affected by a service outage due to some issues with the network infrastructure in that area that began recently. We are investigating the cause but do not have any more information at this time, or an ETA when it will be resolved.
Posted Aug 20, 2025 - 21:42 EDT
This incident affected: Arizona (Nogales).