Simply Bits intermittent outage affecting South Tucson / Eastland Heights Area

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 13:20 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2025 - 11:32 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 13, 2025 - 20:01 EDT

Investigating

We are experiencing intermittent outages affecting South Tucson / Eastland Heights area - Our engineering team is currently diagnosing the issue and working diligently on a repair. Thank you sincerely for your patience.
Posted Mar 13, 2025 - 19:37 EDT
This incident affected: Arizona (Tucson).