The outage should be resolved at this time. Our records show all affected customers are back online. Once again, thank you for your patience!
Posted Jul 16, 2025 - 21:23 EDT
Update
Our techs are working on this fiber issue at this time. They are splicing and we should have more info soon. Current estimated ETA is 10:30 EST. We appreciate your patience.
Posted Jul 16, 2025 - 21:06 EDT
Update
Work on the repairs has already begun, and we have an approximate time of 11pm ET for when we hope the repairs will be fully completed. However, we will provide more information as it becomes available.
Posted Jul 16, 2025 - 19:15 EDT
Identified
Our technicians have identified the issue as a fiber cut in the area due to road construction. We will need to install some new conduit and re splice fibers on site. We do not have an ETA at this time.
Posted Jul 16, 2025 - 16:10 EDT
Investigating
We are seeing an outage in Wake Forest NC affecting approx 110 customers. Our technicians are aware and we are investigating the cause. More updates to come.
Posted Jul 16, 2025 - 15:12 EDT
This incident affected: North Carolina (Wake Forest, NC).