Holly Springs, North Carolina

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 08:08 EDT

Monitoring

A fix has been implemented and we are starting to see affected customers with their services restored. If you are still experiencing problems, kindly reboot your router and fiber ONT. If the issue persists, please contact us at 1-844-846-4994 for further individual troubleshooting.
Posted Jun 28, 2025 - 22:21 EDT

Investigating

Ting Internet engineers are investigating reports of an outage impacting customers in Holly Springs. We will post further information as soon as it becomes available.
Posted Jun 28, 2025 - 21:04 EDT
This incident affected: North Carolina (Holly Springs, NC).