Simply Bits Network outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jun 28, 2025 - 04:25 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 28, 2025 - 02:58 EDT

Investigating

A tech is enroute to resolve the issue on the network
Posted Jun 28, 2025 - 02:49 EDT
This incident affected: Arizona (Tucson, Catalina, Amado, Douglas, Green Valley, Marana, Mt. Lemmon, Nogales, Oracle, Oro Valley, Rio Rico, Sahuarita, San Manuel, Tubac, Vail).