Colorado Springs, CO

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 08:57 EDT

Update

We are still looking and investigating the root cause of the issue. Will update as more information becomes available.

Thank you for your patience as we continue to work on this and resolve it as soon as possible.
Posted Sep 14, 2026 - 17:09 EDT

Update

Our techs are on site still investigating the cause of the issues here.
Posted Sep 14, 2026 - 13:34 EDT

Investigating

We are experiencing some issues causing degraded service for a small group of customers in the Colorado Springs market. Our techs are investigating and we will provide updates as they come.
Posted Sep 14, 2026 - 11:36 EDT
This incident affected: Colorado (Colorado Springs, CO).