Ting Internet - Partial Outage in Wake Forest, NC

Incident Report for Ting Internet

Resolved

It has been determined that the issue was caused by an outage of commercial power in the area. The majority of Ting customers have had service already restored and Wake Electric is continuing to complete their restoration work.
Posted May 22, 2025 - 18:27 EDT

Identified

Ting Internet engineers are on scene with Wake Electric engineers. We are working to determine if any fiber was impacted in the strike along with the electrical power outage to the neighborhood.
Posted May 22, 2025 - 16:12 EDT

Investigating

Ting Internet engineers are investigating an outage affecting some customers in Wake Forest, NC. We will provide further information as soon as possible.
Posted May 22, 2025 - 15:20 EDT
This incident affected: North Carolina (Wake Forest, NC).