This issue should be resolved at this time. We will continue monitor this.
Posted Oct 28, 2025 - 16:27 EDT
Update
We've noticed during our investigation and from customer reports that some Yealink devices are affected as well. A fix we implemented earlier seemed to resolve the issue for most Yealink phones. If you have a Yealink device, feel free to reboot it to see if the issue resolves. We are continuing to investigate to resolve the issue as a whole. Thank you for your patience!
Posted Oct 28, 2025 - 13:28 EDT
Investigating
We are currently investigating a service issue that is affecting Polycom VoIP phones. Any Yealink VoIP phones are unaffected. This is affecting incoming/outgoing calls for Polycom phones. We have a workaround we can implement case by case until this is resolved, if you contact SimplyBits support. We do not have an ETA yet and are still working to identify and troubleshoot the issue.