Ting Internet - Charlottesville, VA - Jefferson Ridge Apartments
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Jan 27, 2025 - 18:43 EST
Identified
Please note Jefferson Ridge Apartments is currently experiencing intermittent power issues which is impacting internet service for the residents there. We are working with their property management team to help address their power issues to restore full service as soon as possible, and we will provide updates as they become available.
Posted Jan 20, 2025 - 13:20 EST
This incident affected: Virginia (Charlottesville, VA).