Durango Service Outage - Near 72 Shuttle St

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Aug 22, 2025 - 15:38 EDT

Identified

We have identified an issue with power for our network equipment providing service to multiple commercial customers near 72 Shuttle St in Durango CO. We are working with the building owner/management to resolve the issue as soon as possible, but do not have an ETA yet when power will be restored for our equipment.
Posted Aug 20, 2025 - 09:39 EDT
This incident affected: Colorado (Durango, CO).