A fix has been successfully implemented, and we are beginning to see services restored for affected customers. If you are still experiencing connectivity issues, please try rebooting your router and fiber ONT. We will continue to monitor the network closely to ensure stability and prevent any further disruptions. Thank you for your continued patience and understanding.
Posted Jun 16, 2025 - 10:28 EDT
Update
The work required to repair the impacted equipment is more complicated and expansive than first identified. We are currently looking at a minimum 5 hours to restoration. We appreciate your patience.
Posted Jun 16, 2025 - 08:19 EDT
Update
Technicians are onsite and getting ready to replace the impacted equipment. Once that is completed we should see service restored to impacted customers. We will update further once repairs have started. Thanks for your patience.
Posted Jun 16, 2025 - 08:01 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 16, 2025 - 07:59 EDT
Identified
We have identified the issue, which is power-related, and are working to get service restored as quickly as possible. Will keep you posted as more information becomes available.
Posted Jun 16, 2025 - 07:17 EDT
Investigating
We have identified a minor service outage affecting a few customers in Charlottesville, VA. At this time, we do not have an ETA for when the service will be restored, but we will post updates as they become available.
Posted Jun 16, 2025 - 06:00 EDT
This incident affected: Virginia (Charlottesville, VA).