Simplybits.com page currently having technical issues

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 18:55 EST

Investigating

We are currently experience an issue with reaching www.Simplybits.com where some users are receiving a 401 error. Please be patient as we investigate this further and hope to resolve this as quickly as possible and restore full service to www.Simplybits.com.

Thank you for your patience
Posted Nov 03, 2025 - 14:31 EST
This incident affected: Ting Website, Shop & Your Account.