Partial Outage in Charlottesville

Incident Report for Ting Internet

Resolved

This issue is part of the power issue we are currently onsite to repair. Please follow that update for further information.
Posted Jun 16, 2025 - 08:02 EDT

Investigating

We are currently seeing a partial outage in the Barracks Rugby area in Charlottesville. Our technicians have been notified and will investigate.
Posted Jun 15, 2025 - 18:45 EDT
This incident affected: Virginia (Charlottesville, VA).