Ting Internet engineers have completed repairs and we are seeing services restored. If you continue having any issues, please reach out to our technical support team at 1-855-846-4994.
Posted Apr 03, 2025 - 19:57 EDT
Update
We have begun repairs. We are currently looking at getting service fully repaired 9 PM EDT. We will continue to update as new information becomes available.
Posted Apr 03, 2025 - 18:54 EDT
Update
Our field engineers have just confirmed that other contractors have completed their work, and Dominion is currently making adjustments to their slack. Once this is finished, we will be able to begin our repairs. Thank you for your patience.
Posted Apr 03, 2025 - 17:34 EDT
Identified
Ting Internet engineers are on-site and have identified the issue; repairs will begin shortly. We will provide an ETA as soon as possible.
Posted Apr 03, 2025 - 14:15 EDT
Investigating
We are investigating an issue impacting service for about 4 customers in Charlottesville VA. We will provide more information as it becomes available
Posted Apr 03, 2025 - 11:30 EDT
This incident affected: Virginia (Charlottesville, VA).