Small outage in Rolesville in North Carolina

Incident Report for Ting Internet

Identified

We have identified the damage. Currently we will need to work towards fixing the fiber optic cable. We currently have an expectation of all services being restored for around 2 AM.

Thank you for your patience while we work to resolve the issue as quickly as possible.
Posted May 11, 2026 - 16:52 EDT

Update

We are still investigating the cause of the outage. We will update as more information becomes available.

Thank you for your patience.
Posted May 11, 2026 - 15:20 EDT

Investigating

We are currently seeing a small group of customers offline. Please stand by as we go to investigate the cause of the outage.

We will update information as it becomes available.

Thank you for your patience.
Posted May 11, 2026 - 12:59 EDT
This incident affects: North Carolina (Rolesville, NC).