Simply Bits - Intermittent calling issues for some Business customers

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 18:55 EDT

Monitoring

Update - Our platform is stabilizing, and calls are now completing successfully. We continue to monitor the situation as we work toward full restoration.
Posted Mar 27, 2025 - 15:24 EDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 27, 2025 - 15:03 EDT

Identified

Identified - A major fiber provider has experienced a "metro isolation" event in California, leading to significant impact to those customers currently registered to our Sacramento data center. We are presently working to move all registrations and call traffic to our Ashburn data center to alleviate this issue. Thank you for your patience.
Mar 27, 2025 - 12:23 MDT
Posted Mar 27, 2025 - 15:00 EDT

Investigating

We are aware of some issues making and receiving calls and are currently investigating.
Posted Mar 27, 2025 - 14:20 EDT
This incident affected: Arizona (Tucson).