SimplyBits - Fax Issues

Incident Report for Ting Internet

Monitoring

Our network provider has implemented a fix and we have confirmed that our fax services are back up and running. If you were affected, please test your fax service now. We are monitoring in the case we get any more reports of issues from customers.
Posted Jun 24, 2025 - 16:11 EDT

Identified

We have identified an issue with our fax services stemming from our network partner. We have reached out to them for investigation and a resolution as soon as possible. No ETA on repair as of yet.
Posted Jun 23, 2025 - 16:53 EDT
This incident affects: Arizona (Tucson).