Fax Services Down for SimplyBits Commercial Customers

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 11:03 EDT

Monitoring

We have received report that our Fax PRI service have been restored and operational. We will monitor through the day to ensure stability. Thank you for your patience on this matter.
Posted Aug 20, 2025 - 12:16 EDT

Identified

We've identified an issue with our Fax PRI, which allows sending/receiving of faxes on our Fax to Go service. We have engaged support from our network partner for a resolution.

Fax services will be automatically restored once a resolution is in place. Thank you for your patience!
Posted Aug 18, 2025 - 14:18 EDT
This incident affected: Arizona (Tucson, Catalina, Amado, Douglas, Green Valley, Marana, Mt. Lemmon, Nogales, Oracle, Oro Valley, Rio Rico, Sahuarita, San Manuel, Tubac, Vail).