Phone and Chat Services Currently unavailable

Incident Report for Ting Internet

Resolved

All services are now back online
Posted Oct 20, 2025 - 06:51 EDT

Identified

Due to an ongoing AWS issue, our phone and chat services are currently unavailable. We are monitoring AWS' status for a resolution at this time.
Posted Oct 20, 2025 - 03:54 EDT
This incident affected: Customer Support.