A fix has been implemented and we are starting to see customer's affected by this outage return online, thank you
Posted Feb 23, 2026 - 21:02 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 23, 2026 - 19:59 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 23, 2026 - 18:57 EST
Update
Our repair crew are still on site working to resolve the outage. We appreciate your patience and will share more information as soon as it’s available.
Posted Feb 23, 2026 - 17:45 EST
Update
Repair crews are actively working to identify the cause of the outage and restore service as quickly and safely as possible. We appreciate your patience and will provide updates as more information becomes available.
Posted Feb 23, 2026 - 13:48 EST
Investigating
We are investigating an issue impacting service for some of our Laguna Woods Village, CA customers. We will provide more information as it becomes available.
Thank you for your patience.
Posted Feb 23, 2026 - 11:41 EST
This incident affected: California (Laguna Woods Village).