Everything should now be up and running and resolved.
Thank you for your patience.
Posted Apr 21, 2026 - 18:56 EDT
Monitoring
Repairs have been completed, and we are seeing connections restored at this time. We will be monitoring the connections closely to ensure there are no further issues. Thank you for your patience.
Posted Apr 21, 2026 - 13:55 EDT
Update
Ting technicians are currently onsite working to repair the fiber damage, with splicing already in progress. We anticipate service will be restored within the next two hours.
Posted Apr 21, 2026 - 09:59 EDT
Identified
We have identified an issue impacting service for some customers in Charlottesville, VA, including direct internet access and enterprise services. Our engineering and field teams are actively working to resolve the problem. We will provide an update as soon as more information becomes available
Posted Apr 21, 2026 - 08:55 EDT
This incident affected: Virginia (Charlottesville, VA).