Ting Internet - Saxony at Encinitas Ranch

Incident Report for Ting Internet

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2026 - 16:32 EDT

Investigating

Ting Internet service at Saxony at Encinitas Ranch is experiencing difficulties. Our engineering team is investigating. As we learn more we'll add the updates to this page. Thanks for your patience while we look into it.
Posted Mar 18, 2026 - 15:46 EDT
This incident affects: California (Encinitas, CA).