This incident is now resolved. If customers are still experiencing issues with your internet service, please power cycle your equipment (turn it off and back on). If your internet service is not restored after power cycling your equipment, please contact our internet support team at 1-844-846-4994 for further assistance.
Posted Nov 26, 2025 - 13:50 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2025 - 22:02 EST
Update
We are continuing to investigate this issue.
Posted Nov 25, 2025 - 20:42 EST
Update
We are still trying to isolate the issue causing the outage. Please power cycle your equipment if you are offline. If it is still offline, we are continuing to isolate the issue and hope to resolve it quickly.
Thank you for your patience.
Posted Nov 25, 2025 - 17:29 EST
Investigating
We are experiencing a small outage in Laguna Woods Village affecting roughly 15 customers. We are still investigating the cause at this time and will add updates when able.
Posted Nov 25, 2025 - 14:21 EST
This incident affected: California (Laguna Woods Village).