Holly Springs Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 21:34 EDT

Investigating

We're seeing a few customers in Holly Springs offline. This is affecting a few addresses on Texanna Way specifically. Our techs are in route to find the problem. No ETA at this time.
Posted Aug 20, 2025 - 19:58 EDT
This incident affected: North Carolina (Holly Springs, NC).