If any customers are experiencing their service offline, please power cycle your equipment. If this does not resolve the issue please call internet support at 1-844-846-4994, thank you
Posted Dec 19, 2025 - 20:24 EST
Update
Our network technicians are still on-site and actively working to restore service for the remaining impacted customers. We appreciate your patience and will share further updates as soon as more information is available
Posted Dec 19, 2025 - 18:35 EST
Update
Restoration work has been underway all morning and we are seeing most customers online at this time. We are continuing to investigate to ensure we've repaired all customers impacted.
Posted Dec 19, 2025 - 13:35 EST
Update
Restoration efforts for remaining customers will resume tomorrow morning. We appreciate your continued understanding
Posted Dec 18, 2025 - 22:32 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 18, 2025 - 21:44 EST
Update
We are continuing to investigate this issue.
Posted Dec 18, 2025 - 17:39 EST
Investigating
We are seeing another small number of customers offline at the moment and we are investigating the issue, thank you
Posted Dec 18, 2025 - 14:30 EST
This incident affected: California (Laguna Woods Village).