Ting Internet - Partial Outage in Rolesville, NC.

Incident Report for Ting Internet

Identified

We have located the damaged Fiber optic cable and have started work to restore service. Please stand by as more information becomes available we will continue to update information.

Thank you for your patience.
Posted Apr 08, 2026 - 13:27 EDT

Investigating

Ting Internet engineers are investigating reports of an outage affecting some parts of Rolesville, NC. We will post more information as soon as possible.
Posted Apr 08, 2026 - 10:47 EDT
This incident affects: North Carolina (Rolesville, NC).