Carbondale, CO - Power outage

Incident Report for Ting Internet

Resolved

Power has been restored to the area, and it appears all customers should be back online
Posted Jun 22, 2025 - 01:54 EDT

Identified

It appears there is a power outage impacting our service in the Carbondale area.

We will continue to investigate and post any additional information and go from there.
Posted Jun 21, 2025 - 22:31 EDT
This incident affected: Colorado (Carbondale, CO, Glenwood Springs, CO).