Partial Outage in Memphis TN.

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 08:52 EDT

Identified

We are currently experiencing a service outage affecting some customers in the Memphis, Tennessee area. The issue appears to be related to fiber damage caused by nearby construction. Our teams are actively working to restore service as quickly as possible. While there is currently no estimated time of restoration, we will provide updates as more information becomes available.
Posted Oct 25, 2025 - 01:39 EDT
This incident affected: Tennessee (Memphis).