Our technicians are still working to get the last 5 affected customers on line. Unfortunately the repair is more extensive than first thought and the new ETA for repair is approx 10PM this evening. Apologies and as always thank you for your patience.
Posted May 19, 2025 - 16:26 EDT
Identified
Our technicians are still working to get the last 5 affected customers on line. The current ETA is approx 7PM this evening. Thank you for your patience.
Posted May 19, 2025 - 14:04 EDT
Update
We are seeing a small outage in Holly Springs affecting roughly 10 customers right now but repairs may cause further issues in Oakhall neighborhood. Our technicians are on site. We will update when we have more info. No ETA at this time.
Posted May 19, 2025 - 11:09 EDT
Investigating
We are seeing a small outage in Holly Springs affecting roughly 10 customers. Our technician is on the way to the site. We will update when we have more info. No ETA at this time.
Posted May 19, 2025 - 10:24 EDT
This incident affected: North Carolina (Holly Springs, NC).