The fix has been implemented and everyone should now be online. Please restart your equipment if you are offline.
Thank you for your patience as we put forth the fix!
Posted Sep 25, 2026 - 20:56 EDT
Identified
We have a fix that should be in place getting the small outage back online. Please stand by while we wait and test the resolution put in place.
Thank you for your patience
Posted Sep 25, 2026 - 20:24 EDT
Investigating
Currently repairs are ongoing. We hope to have customers back online shortly.
Thank you for your patience while we continue to work.
Posted Sep 25, 2026 - 17:57 EDT
Identified
We have identified the location of the damage where the buried fiber was cut. We are coordinating with our contractor to replace the damaged fiber and complete the necessary splicing. We will provide further updates as restoration work progresses.
Posted Sep 25, 2026 - 16:31 EDT
Investigating
Some customers in Laguna Woods Village, CA are without internet service right now, and our engineers are already on it. We'll post an update here as soon as we have one.
Customers in the affected area don't need to restart anything — service will come back on its own once the fix is in. We appreciate everyone's patience while we work on this.
Posted Sep 25, 2026 - 09:30 EDT
This incident affected: California (Laguna Woods Village).