Charlottesville VA Outage

Incident Report for Ting Internet

Update

Our field techs are still investigating but this outage may have been caused by a power outage area of our equipment. Will update further when we can confirm. No ETA at this time.
Posted Nov 22, 2025 - 16:34 EST

Investigating

Ting Internet engineers are investigating reports of an outage impacting service for some customers in Charlottesville, VA. We will post further information and next steps here as soon as it becomes available.
Posted Nov 22, 2025 - 16:07 EST
This incident affects: Virginia (Charlottesville, VA).