Ting Internet - Rolesville, NC - Partial Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Dec 23, 2025 - 09:49 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 22, 2025 - 19:29 EST

Update

Repairs continue on the fiber as customer will start coming back online shortly.

Thank you for your patience and understanding as we continue to work quickly to restore service.
Posted Dec 22, 2025 - 19:03 EST

Update

Crews are on site and the fiber repair is underway to fix customers on Pluton Place in Rolesville, NC.
Posted Dec 22, 2025 - 18:16 EST

Identified

Ting Internet engineers are investigating reports of an outage impacting service for some customers in the area of Pluton Place in Rolesville, NC. We will post further information and next steps here as soon as it becomes available.
Posted Dec 22, 2025 - 16:18 EST
This incident affected: North Carolina (Rolesville, NC).