Phone and Chat services degraded. Help Center services may be inaccessible.

Incident Report for Ting Internet

Resolved

The Amazon outage impacting the internet today has been confirmed as resolved and our phone system should be up and running.

Thank you for your patience and understanding.
Posted Oct 20, 2025 - 19:01 EDT

Update

Amazon have addressed a number of issues with their AWS service and we are seeing some calls and chats now working as expected. Customers may still experience delays as Amazon works to alleviate all outstanding service impacts.
Posted Oct 20, 2025 - 14:57 EDT

Update

Our help center is now also impacted by the ongoing AWS issues.
Posted Oct 20, 2025 - 12:14 EDT

Identified

Due to the ongoing AWS issues, our phone and chat services are seeing degraded performance. We will continue to monitor as Amazon works to correct.
Posted Oct 20, 2025 - 11:10 EDT
This incident affected: Customer Support.